サーバーを移転したらhttpsでちゃんと表示してくれない!

目安時間 6分
  • twitterへのtweet
  • はてなブックマーク
  • 人気ブログランキング

現在、メインのレンタルサーバーのお引っ越し中です。

 

で、https://〇〇では、表示されないのですが

 

http://でなら表示されるんです。

 

さ~何が原因かわからない!

サーバーを移転したらhttpsでちゃんと表示してくれない!

実際、どのように表示されていたかというと

 

と載せたいのですが、ちょっと問題があるので、

このサイトで試そうとしたのですが

 

・・・

 

あ!

変わらない。

 

という事で、ダメでした。

 

簡単に言うと、

同じ画像が2個、表示されたり

 

ヘッダーのメニューが左に一列に並んでいたりしていたんです。

 

何がどうしてそうなったんだか?

という話です。

 

今回は、SSL化もちゃんとしたのに、

なんで、SSL化のサイトできちんと表示されないのか

という話です。

サーバーの移転でサイトが表示されなくなった

サーバーの移行でサイトが表示されなくなったので

 

まずは、エクスポートを疑いました。

 

私は、

「All-in-One WP Migration」

 

を使ってワードプレスの引っ越しをしますので、

エクスポートを疑いました。

 

順に、バックアップしていたのを、表示させたら

半年前のだと

問題なくhttpsのサイトでも表示されます。

 

う~ん

 

最近、バックアップしたのが悪いという事ですよね。

 

ただ、昔の普通に表示されて、新しいのは表示されない

という事は、

 

原因はたいしたことではないのでは?

 

という事で、グーグル先生に質問しました。

 

う~ん、それらしいことは書いておりません。

 

あ~これは時間がかかるやつだなと思ったので、

サーバーのメール質問を使う事にしました。

 

24時間以内に返事があるという事でしたので

明日かと思っていたのですが

 

一時間かかっておりませんね。

 

ビックリしました!

どうやって、サイトが表示されるようになったか

このようなメールが届きました。

チンプンカンプン!

 

というわけにはいかないのと、

この文面でいくと

httpとhttpsがごちゃ混ぜになっているというような話です

 

う~ん、

これを一つ一つ探さなきゃいけないの?

 

画像の一番下に

■Webサイトの常時SSL化

とあります。

 

ここは読んだんだけどな~

 

しかし、質問をして、回答をもらってから見るのでは違いますね。

 

ヒントがありました!ここ

 

■Webサイトの常時SSL化
https://www.xserver.ne.jp/manual/man_server_fullssl.php
このこのページのこの部分

 

という事で早速!

ワードプレスの「設定」→「一般」から

「WordPress アドレス(URL)」「サイトアドレス(URL)」の設定内容を、httpsから始まるようにしましょう。

四角く囲っている部分を変更します。

 

私のは、両方ともhttpになっておりました。

httpsに書き換えて、変更を保存を押したら~

 

ちゃんとhttpsでも表示されるようになりました!

画像などを調べなくて済んだので、一安心です。

まとめ

今回の件で、わかったことが2つ

 

・エックスサーバーのメール質問の返信が早いという事

(たまたまだったとしてもうれしい)

 

・ちょっとした事で、サイトの表示がおかしくなる

(当たり前と言えば当たり前)

 

いや~

いい勉強になりました。

 

ググって、そして、

サーバーのQ&Aを見てもわからなかったら

相談するのもありですね!

 

何でもかんでも相談するのは

まずいと思いますけど!!

  • twitterへのtweet
  • はてなブックマーク
  • 人気ブログランキング

この記事に関連する記事一覧

コメントフォーム

名前 

 

メールアドレス 

 

URL (空白でもOKです)

 

コメント

CAPTCHA


日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)

トラックバックURL: 
エクアド エクアド"/
アドセンスとアフィリエイトを使い分けて稼ぐ「エクアド」
カテゴリー
最近の投稿